Futurama   Planet Express Employee Lounge
The Futurama Message Board

Design and Support by Can't get enough Futurama
Help Search Futurama chat Login Register

PEEL - The Futurama Message Board    The Wish Void    Avatars for non IE or NS users? « previous next »
Author Topic: Avatars for non IE or NS users?  (Read 422 times)
Pages: [1] Print

Starship Captain
« on: 11-11-2003 16:48 »

I switched to Mozilla Firebird as my default browser a while back, and just checked my PEEL profile. Except a little notice appeared telling me I had to be using Internet Explorer or Netscape to view the images for avatars.

Any chance us folks with the wonderful tabbed browsing functionality could get to see the images?

Mozilla is a lot like NS in many ways anyway.

Space Pope
« Reply #1 on: 11-11-2003 17:03 »

make a screenshot . . .
i use neither IE nor NS and i can see avatars. weird.

Space Pope
« Reply #2 on: 11-11-2003 17:07 »

I've never heard of people on Mozilla Firebird having problems.

I use Avant Browser, uses IE but has useful features such as tabbing.
Starship Captain
« Reply #3 on: 11-11-2003 17:34 »

I don't see that it is a problem. I get the same thing but my usage of the site is totaly unaffected and I'm not sure where those picures it refers to are anyway. Note: peoples avatars apear next to posts as usual, this is some random thing on the preferences/settings/whatever screen

DOOP Secretary
« Reply #4 on: 11-12-2003 03:22 »

I just clicked OK and that disappeared, images showed up just fine.

Bending Unit
« Reply #5 on: 11-12-2003 07:07 »

It works fine in Konqueror (which uses its own KHTML renderer).  99% of the problems with Konqueror and compatibility is that the website's author has delibrately blocked you or has poorly coded it.

Looking at the source code, the only time that the 'You need NS 4 or IE 4' error should popup is if the 'document.all' or 'document.layers' objects don't exist, or the interpreter doesn't like 'elseif'.  It could be coded the long hand way to prevent this:

function generateimage(which){
if (document.all){
dynamic3.innerHTML='<center>Loading image...</center>';
dynamic3.innerHTML='<img src="'+which+'">';
} else {
} else {
 if (document.layers){
document.dynamic1.document.dynamic2.document.write('<img src="'+which+'">');
} else {
else {
alert('You need a browser that supports document layers, such as Netscape 4 or IE 4 to view the images!');
(I haven't tested the code, but it shoould work)
Pages: [1] Print 
« previous next »
Jump to:  

Powered by SMF | SMF © 2006, Simple Machines | some icons from famfamfam
Legal Notice & Disclaimer: "Futurama" TM and copyright FOX, its related entities and the Curiosity Company. All rights reserved. Any reproduction, duplication or distribution of these materials in any form is expressly prohibited. As a fan site, this Futurama forum, its operators, and any content on the site relating to "Futurama" are not explicitely authorized by Fox or the Curiosity Company.
Page created in 0.084 seconds with 17 queries.